This project is read-only.

Older version v2.0.2 not working

Apr 23, 2014 at 2:42 PM
Hi Kent,

I'm having trouble using KBCsv on a project that targets Framework 4.0. Because my client wants me to support Windows XP still, I can not move to Framework 4.5. Therefore I'm stuck with using KBCsv v2.0.2. However, when I install it using NuGet, and try to use it, I get a compilation warning:

Found conflicts between different versions of the same dependent assembly that could not be resolved. These reference conflicts are listed in the build log when log verbosity is set to detailed.

followed by the error:

Assembly 'Kent.Boogaart.KBCsv, Version=, Culture=neutral, PublicKeyToken=cc96fa93a217f7a1' uses 'Kent.Boogaart.HelperTrinity, Version=, Culture=neutral, PublicKeyToken=cc96fa93a217f7a1' which has a higher version than referenced assembly 'Kent.Boogaart.HelperTrinity, Version=, Culture=neutral, PublicKeyToken=cc96fa93a217f7a1'

Trying to resolve this by upgrading the HelperTrinity to version 1.5.3 leads to several more compilation warnings:

The primary reference "D:...\MyLibrary.dll" could not be resolved because it has an indirect dependency on the framework assembly "System.Runtime, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.0". To resolve this problem, either remove the reference "D:...\MyLibrary.dll" or retarget your application to a framework version which contains "System.Runtime, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".

and even more errors.

Is this an error in the package, or is something else going on?
Apr 29, 2014 at 12:57 PM
Hi Edalb,

Looks to be an error in the package - apologies for that. It might be a tad too difficult to rectify it now, but I'll take a look when I get a chance.

That said, once I upgraded to The Helper Trinity 1.5.3, everything worked fine for me. Which version of VS are you using? I tried in 2013.

May 1, 2014 at 9:33 AM
Hi Kent,

I have by now also managed to resolve the issue by upgrading to The Helper Trinity 1.5.3. Turns out that, because I was fairly new to using NuGet, I didn't do the upgrade correctly (running Install-Package instead of Upgrade-Package), but a colleague set me on the right path. After that, and linking the Bcl package to all my projects, things worked out ok.

Perhaps it is still worth it to release a version v2.0.3 which has the correct dependencies?

Thanks for investigating this, and for providing this awesome package.

Best regards,